It is currently 18. Sep 2019, 22:40


LiWi mag nicht mehr nach Änderung der ASP-Config

Fragen zum Webinterface v4.x

Moderator: Moderator Team

  • Author
  • Message
Offline

uziegler

Power User

Power User

  • Posts: 63
  • Joined: 28. Oct 2008, 14:48

LiWi mag nicht mehr nach Änderung der ASP-Config

Post4. Dec 2008, 15:13

:?
Hallo @All,

ich wollte den SessionTimeout für das Webinterface heraufsetzen. Mein Fehler war, dass ich es über den IIS-Konfigurator getan habe. Der Wert für DefaultSessionTimeout wurde zwar erfolgreich in die web.config geschrieben, leider sind dabei auch ein großer Teile der LiWi-Einträge verschwunden.

Wenn ich jetzt das Webinterface über den IE starte kommt die Meldung:

Error:System.NullReferenceException
Message: Object reference not set to an instance of an object
Source: liwi
at ViewGenerator.Init()

Kann mir jemand sagen, wie ich das Problem schnell wieder in den Griff bekomme oder eine "leere" original web.config vom Webinterface zur Verfügung stellen?

Unsere Konfig:
LOGINventory 4.5.7.0
WebInterface: 4.5.8.1 Build 1394


EDIT:___________________________________________________
Die originale web.config habe ich mir aus meinen ersten Gehversuchen in einer VM wieder geholt. Das Problem an sich ist gelöst.

Aber meine prinzipielle Frage bleibt: Warum wird die web.config durch das IIS GUI unbrauchbar gemacht??
Gruß
Uwe
________________________________
Was nicht passt wird passend gemacht
Offline
User avatar

MarcoM

Moderator

Moderator

  • Posts: 406
  • Joined: 1. Sep 2003, 01:00

Post5. Dec 2008, 12:46

Hallo,

Der SessionTimeout wird im Webinterface über den Key "DefaultSessionTimeout" in der Web.config gesetzt. Ein Setzen eines Timeouts über die IIS GUI sollte jedoch keine Probleme bereiten. Wir werden das Verhalten untersuchen.
Marco Maier

Stay tuned ..

LOGINventory Video Tutorials


LOGIN Expert Blog


LOGINventory Developer Blog



Return to WebInterface

Who is online

Users browsing this forum: No registered users and 10 guests

cron