It is currently 15. Aug 2018, 01:22


[Abgetrennt:] Lange Startzeit

Version 6.6.5 wurde veröffentlicht im Mai 2016 - EOL seit Ende 2016!

Moderator: Moderator Team

  • Author
  • Message
Offline
User avatar

Franky

Moderator

Moderator

  • Posts: 386
  • Joined: 30. Nov 2004, 15:32

[Abgetrennt:] Lange Startzeit

Post3. Jun 2015, 10:33

Noch eine Anmerkung zur "langen" Startzeit:
Diese hängt von diversen Faktoren ab: 32-Bit oder 64-Bit, lokaler Start oder über Netzwerk-Share, Daten-Menge im Dashboard.

Bei meinen "Messungen" ergeben sich z.B. diese Werte:
- 5 Jahre alter Desktop mit 32-Bit Windows und lokaler Start: ca.10 s = 5s Splash, 2s Init, 3s Dashboard :mrgreen:
- Aktueller Laptop mit 64-Bit Windows und Start vom Netz: ca. 18s = 8s Splash, 5s Init, 4s Dashboard 8)

Während das Dashboard berechnet wird, kann übrigens schon bedient / navigiert werden.
[UPDATE:]
Falls das Root-Dashboard ausgeschaltet werden soll, da kann man anliegende Datei entzippen und statt dessen im Root als "Dashboard importieren". Das gilt dann für alle Anwender.
root-leer.zip
Dashboard ohne Inhalt
(282 Bytes) Downloaded 85 times
Franky

Smile, You're on Candid Camera :)
Video Tutorials: http://www.loginventory.com/videos
Offline

sckl

Power User

Power User

  • Posts: 35
  • Joined: 16. Jan 2014, 14:10

Re: Lange Startzeit

Post8. Jun 2015, 08:13

diese "Messungen" kann ich so nicht bestätigen :?

Habe auf 3 Systemen den Start durchgeführt, und der "Splash" dauert immer zwischen 27 und 30 Sekunden
Die Systeme
- ThinkPad T440s mit SSD/8GB RAM/Win7Ent x64 / Gigabit Ethernet
- VMware Server Win 2012R2 x64 4GB RAM/4CPU / 10GBit
- Physischer Server mit 96GB RAM/2 Quad Cores E5-2643@3.3 GHz/Enterprise SSD Win 2012R2 x64 / 10 GBit

Der Init bzw. Dashboard ist recht flott.

Franky wrote:Noch eine Anmerkung zur "langen" Startzeit:
Diese hängt von diversen Faktoren ab: 32-Bit oder 64-Bit, lokaler Start oder über Netzwerk-Share, Daten-Menge im Dashboard.

Bei meinen "Messungen" ergeben sich z.B. diese Werte:
- 5 Jahre alter Desktop mit 32-Bit Windows und lokaler Start: ca.10 s = 5s Splash, 2s Init, 3s Dashboard :mrgreen:
- Aktueller Laptop mit 64-Bit Windows und Start vom Netz: ca. 18s = 8s Splash, 5s Init, 4s Dashboard 8)

Während das Dashboard berechnet wird, kann übrigens schon bedient / navigiert werden.
[UPDATE:]
Falls das Root-Dashboard ausgeschaltet werden soll, da kann man anliegende Datei entzippen und statt dessen im Root als "Dashboard importieren". Das gilt dann für alle Anwender.
root-leer.zip
Offline
User avatar

Franky

Moderator

Moderator

  • Posts: 386
  • Joined: 30. Nov 2004, 15:32

Re: Lange Startzeit

Post9. Jun 2015, 12:38

Dann bitte zum Test einmal das LMC Verzeichnis lokal hin kopieren und LOGINventory.exe von dort lokal starten - und dann neu "messen".
Franky

Smile, You're on Candid Camera :)
Video Tutorials: http://www.loginventory.com/videos
Offline

sckl

Power User

Power User

  • Posts: 35
  • Joined: 16. Jan 2014, 14:10

Re: Lange Startzeit

Post9. Jun 2015, 12:41

Franky wrote:Dann bitte zum Test einmal das LMC Verzeichnis lokal hin kopieren und LOGINventory.exe von dort lokal starten - und dann neu "messen".


hatte ich beim Test schon. Beim VMware Server war es die "installierte" Version, bei den anderen die PortableLMC, welche zuerst lokal hinkopiert wurde
Offline
User avatar

Franky

Moderator

Moderator

  • Posts: 386
  • Joined: 30. Nov 2004, 15:32

Re: Lange Startzeit

Post9. Jun 2015, 12:56

Dann tippe ich auf den Virenscanner.
Testweise einmal das entsprechende Verzeichnis ausschließen...
Franky

Smile, You're on Candid Camera :)
Video Tutorials: http://www.loginventory.com/videos
Offline

sckl

Power User

Power User

  • Posts: 35
  • Joined: 16. Jan 2014, 14:10

Re: Lange Startzeit

Post11. Jun 2015, 08:15

Franky wrote:Dann tippe ich auf den Virenscanner.
Testweise einmal das entsprechende Verzeichnis ausschließen...


Keine Besserung. Auch abschalten des Virenscanners hat nichts gebracht.

Wird beim Start bereits auf die Datenbank zugegriffen? Hängt evtl. die Berechtigungskonfiguration damit zusammen?
Offline
User avatar

StefanS

Moderator

Moderator

  • Posts: 228
  • Joined: 1. Jul 2009, 10:58

Re: [Abgetrennt:] Lange Startzeit

Post12. Jun 2015, 10:45

Hallo,

zu allererst: In Version 6.5.3 wurde das Problem mit der Berechtigungsperformance beim Start (eigentlich) erfolgreich behoben - setzen Sie schon 6.5.3 ein?
beim Starten (also während der Splash angezeigt wird) wird die Baumstruktur im Hintergrund schon geladen - also generell kann man das Problem mit der Berechtigung nicht ganz ausschließen.

Können Sie uns ggf. die Datenbank zur Analyse zur Verfügung stellen? Hier können wir das Problem (derzeit) leider nicht nachvollziehen.
mfg
StefanS
Offline

sckl

Power User

Power User

  • Posts: 35
  • Joined: 16. Jan 2014, 14:10

Re: [Abgetrennt:] Lange Startzeit

Post12. Jun 2015, 11:16

StefanS wrote:Hallo,

zu allererst: In Version 6.5.3 wurde das Problem mit der Berechtigungsperformance beim Start (eigentlich) erfolgreich behoben - setzen Sie schon 6.5.3 ein?
beim Starten (also während der Splash angezeigt wird) wird die Baumstruktur im Hintergrund schon geladen - also generell kann man das Problem mit der Berechtigung nicht ganz ausschließen.

Können Sie uns ggf. die Datenbank zur Analyse zur Verfügung stellen? Hier können wir das Problem (derzeit) leider nicht nachvollziehen.


Hallo,

ja - 6.5.3 ist im Einsatz. Die Auswirkung der Änderung ist aber, nachdem der Splash-Screen weg ist (hier waren zuvor 45 zusätzliche Sekunden fällig)


Unsere Baum-Struktur ist sehr umfangreich, da wir v.A. die Software-Pakete sehr detailiert aufgegliedert haben und das Lizenzmanagement auch darauf aufsetzt. Die DB kann ich zur Verfügung stellen, ich melde mich diesbzgl. nächste Woche.
Offline
User avatar

Franky

Moderator

Moderator

  • Posts: 386
  • Joined: 30. Nov 2004, 15:32

Re: [Abgetrennt:] Lange Startzeit

Post18. Jun 2015, 12:43

Die Analyse der Datenbank hat ergeben, dass über 36000 Knoten / Abfragen vorhanden sind. In einer "leeren" Datenbank sind ca. 150 Knoten vordefiniert.
Bei generieren der Baum-Struktur in dem LMC werden während des Splash-Screens etwa 1000 Knoten / Abfragen pro Sekunde verarbeitet.

Möglicherweise sind auch Abfragen vorhanden, die ursprünglich aus v5 importiert wurden und die nicht mehr benötigt werden. Wahrscheinlich hilft es dann schon, diese zu entfernen und damit die Anzahl kräftig zu reduzieren.
Franky

Smile, You're on Candid Camera :)
Video Tutorials: http://www.loginventory.com/videos

Return to LOGINventory6 Deutsch

Who is online

Users browsing this forum: No registered users and 1 guest

cron