Page 1 of 1

Webinterface 6.5.3 - keine Aktualisierung der Ergebnisse

PostPosted: 27. May 2015, 18:43
by surveyor
Hallo,
ich habe nach Installation der Version 6.5.3 das Webinterface im Konfigurationstool neu veröffentlicht und danach in die von mir erzeugten Analysen geschaut. Alles sah gut aus.

Danach habe ich an einer Analyse Änderungen vorgenommen, die das Ergebnis massiv verändert hat. Es war mit aber mit der angezeigten Schaltfläche im Browser nicht möglich, die Analyseergebnisse zu aktualisieren. Auch nach einem Beenden und Neustart des Browsers wurden immer wieder die alten Ergebnisse angezeigt.

Wie kann ich die Analysen im Webinterface aktualisieren?

Re: Webinterface 6.5.3 - keine Aktualisierung der Ergebnisse

PostPosted: 28. May 2015, 07:58
by surveyor
Nachtrag:
Heute morgen sind die Ergebnisse aktualisiert. Muss man sich dafür aus- und wieder einloggen oder haben die Ergebnisse jetzt ein gewisses Alter erreicht und wurden vom Webserver aktualisiert?

Re: Webinterface 6.5.3 - keine Aktualisierung der Ergebnisse

PostPosted: 28. May 2015, 10:41
by StefanS
Hallo Herr Kalski,

vielen Dank für den Hinweis - hier scheint noch ein Problem vorzuliegen. Es scheint ein Problem mit der Session zu sein. Wir schauen uns das Problem an und informieren dann wenn es behoben ist.

Re: Webinterface 6.5.3 - keine Aktualisierung der Ergebnisse

PostPosted: 1. Jun 2015, 10:36
by MarcoM
Hallo Herr Kalski,

das Verhalten ist derzeit bei Design. Die Knotendefinitionen werden pro Applikations-Instanz gecached. Das heißt, auch bei 2 gleichzeitigen LMC auf einem Rechner würde das Verhalten auftreten.
Für die Webanwendung bedeutet das, die Knotendefinitionen bleiben solange im Cache bis alle Sessions beendet sind bzw. der IIS Arbeitsprozess neu gestartet wird.
Diesen können Sie neu starten, indem Sie iisreset auf der administrativen Kommandozeile auf dem Webserver ausführen, den IIS bzw. den LOGINventory6 Anwendungspool über die IIS MMC neu starten.

Eine Seesion wird nicht durch schließen eine des Browser-Fensters beendet, sondern nach Ablauf des Session-Timeout. Wenn also über x Minuten kein Request mehr vom Client kam.
Dieser Timeout ist konfigurierbar (https://technet.microsoft.com/de-de/lib ... 10%29.aspx).

Re: Webinterface 6.5.3 - keine Aktualisierung der Ergebnisse

PostPosted: 3. Jun 2015, 19:47
by surveyor
Wenn das wirklich so gewollt ist, sollte der Button zum Aktualisieren aus der Webanwendung entfernt werden. Er ist dann sinnlos.

Re: Webinterface 6.5.3 - keine Aktualisierung der Ergebnisse

PostPosted: 5. Jun 2015, 08:58
by MarcoM
Hallo,

Der Button aktualisiert die Daten. Also neue Assets etc.
Das aktuelle Verhalten ist nicht zwanghaft gewollt, ergibt sich aber aus der derzeitigen Architektur und lässt sich kurzfristig leider nicht korrigieren.